Home

Computing Resources

Browsers Compatible with Echo360

Note: The following compatibility information applies to the EchoPlayer only. The EchoCenter feature is no longer compatible with IE 8, so if you use this feature with Internet Explorer, make sure you upgrade to IE 9 or later.

Note also that Variable Speed Playback (VSP) is only supported by newer browsers that follow the HTML5 standard.

Operating System Internet Explorer 8 & 9 Firefox 15 & 16 Chrome 21 & 22 Safari 5.1 and 6.0
Windows 7 Supported Supported SupportedNot Supported
Mac OS X 10.5 Not Supported Supported SupportedSupported
Mac OS X 10.6Not SupportedSupportedSupported Supported
Mac OS X 10.7Not SupportedSupportedSupported Supported
Linux Red Hat 6Not SupportedSupportedNot Supported Not Supported